libpackagekit-devel-0.7.6-7-rosa2012.1.i586.rpm


Advertisement

Description

libpackagekit-devel - Libraries and headers for PackageKit

Property Value
Distribution ROSA 2012.1
Repository ROSA Main i586
Package name libpackagekit-devel
Package version 0.7.6
Package release 7-rosa2012.1
Package architecture i586
Package type rpm
Installed size 1.03 MB
Download size 77.40 KB
Official Mirror mirror.rosalab.ru
Headers and libraries for PackageKit.

Alternatives

Package Version Architecture Repository
libpackagekit-devel-0.8.11-2-rosa2012.1.i586.rpm 0.8.11 i586 ROSA Main Updates
libpackagekit-devel - - -

Requires

Name Value
devel(libQtCore) -
devel(libQtDBus) -
devel(libQtSql) -
devel(libQtXml) -
devel(libarchive) -
devel(libgcc_s) -
devel(libgio-2.0) -
devel(libglib-2.0) -
devel(libgobject-2.0) -
devel(libsqlite3) -
devel(libstdc++) -
libpackagekit-glib14 == 0.7.6-7
libpackagekit-qt2_2 == 0.7.6-7
libpackagekitglib-gir1.0 == 0.7.6-7
libpackagekitplugin-gir1.0 == 0.7.6-7
pkgconfig(QtCore) -
pkgconfig(QtDBus) -
pkgconfig(QtSql) -
pkgconfig(QtXml) -
pkgconfig(glib-2.0) -
pkgconfig(gobject-2.0) -
pkgconfig(sqlite3) -

Provides

Name Value
devel(libpackagekit-glib2) -
devel(libpackagekit-qt2) -
libpackagekit-devel == 0.7.6-7:2012.1
packagekit-devel == 0.7.6-7
pkgconfig(packagekit-glib2) == 0.7.7
pkgconfig(packagekit-plugin) == 0.7.7
pkgconfig(packagekit-qt2) == 0.7.7

Obsoletes

Name Value
packagekit-qt-devel < 0.7.6

Download

Type URL
Binary Package libpackagekit-devel-0.7.6-7-rosa2012.1.i586.rpm
Source Package packagekit-0.7.6-7.src.rpm

Install Howto

  1. Enable ROSA Main repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libpackagekit-devel rpm package:
    # urpmi libpackagekit-devel

Files

Path
/usr/include/PackageKit/
/usr/include/PackageKit/backend/pk-backend-spawn.h
/usr/include/PackageKit/backend/pk-backend.h
/usr/include/PackageKit/packagekit-glib2/packagekit.h
/usr/include/PackageKit/packagekit-glib2/pk-bitfield.h
/usr/include/PackageKit/packagekit-glib2/pk-catalog.h
/usr/include/PackageKit/packagekit-glib2/pk-category.h
/usr/include/PackageKit/packagekit-glib2/pk-client-helper.h
/usr/include/PackageKit/packagekit-glib2/pk-client-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-client.h
/usr/include/PackageKit/packagekit-glib2/pk-common.h
/usr/include/PackageKit/packagekit-glib2/pk-control-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-control.h
/usr/include/PackageKit/packagekit-glib2/pk-desktop.h
/usr/include/PackageKit/packagekit-glib2/pk-details.h
/usr/include/PackageKit/packagekit-glib2/pk-distro-upgrade.h
/usr/include/PackageKit/packagekit-glib2/pk-enum-types.h
/usr/include/PackageKit/packagekit-glib2/pk-enum.h
/usr/include/PackageKit/packagekit-glib2/pk-error.h
/usr/include/PackageKit/packagekit-glib2/pk-eula-required.h
/usr/include/PackageKit/packagekit-glib2/pk-files.h
/usr/include/PackageKit/packagekit-glib2/pk-media-change-required.h
/usr/include/PackageKit/packagekit-glib2/pk-message.h
/usr/include/PackageKit/packagekit-glib2/pk-package-id.h
/usr/include/PackageKit/packagekit-glib2/pk-package-ids.h
/usr/include/PackageKit/packagekit-glib2/pk-package-sack-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-package-sack.h
/usr/include/PackageKit/packagekit-glib2/pk-package.h
/usr/include/PackageKit/packagekit-glib2/pk-progress.h
/usr/include/PackageKit/packagekit-glib2/pk-repo-detail.h
/usr/include/PackageKit/packagekit-glib2/pk-repo-signature-required.h
/usr/include/PackageKit/packagekit-glib2/pk-require-restart.h
/usr/include/PackageKit/packagekit-glib2/pk-results.h
/usr/include/PackageKit/packagekit-glib2/pk-service-pack.h
/usr/include/PackageKit/packagekit-glib2/pk-source.h
/usr/include/PackageKit/packagekit-glib2/pk-task-sync.h
/usr/include/PackageKit/packagekit-glib2/pk-task.h
/usr/include/PackageKit/packagekit-glib2/pk-transaction-list.h
/usr/include/PackageKit/packagekit-glib2/pk-transaction-past.h
/usr/include/PackageKit/packagekit-glib2/pk-update-detail.h
/usr/include/PackageKit/packagekit-glib2/pk-version.h
/usr/include/PackageKit/packagekit-qt2/Daemon
/usr/include/PackageKit/packagekit-qt2/Eula
/usr/include/PackageKit/packagekit-qt2/Package
/usr/include/PackageKit/packagekit-qt2/Signature
/usr/include/PackageKit/packagekit-qt2/Transaction
/usr/include/PackageKit/packagekit-qt2/bitfield.h
/usr/include/PackageKit/packagekit-qt2/daemon.h
/usr/include/PackageKit/packagekit-qt2/eula.h
/usr/include/PackageKit/packagekit-qt2/package.h
/usr/include/PackageKit/packagekit-qt2/signature.h
/usr/include/PackageKit/packagekit-qt2/transaction.h
/usr/include/PackageKit/plugin/packagekit-plugin.h
/usr/include/PackageKit/plugin/pk-backend.h
/usr/include/PackageKit/plugin/pk-conf.h
/usr/include/PackageKit/plugin/pk-plugin.h
/usr/include/PackageKit/plugin/pk-transaction.h
/usr/lib/libpackagekit-glib2.so
/usr/lib/libpackagekit-qt2.so
/usr/lib/cmake/packagekit-qt2/packagekit-qt2-config-version.cmake
/usr/lib/cmake/packagekit-qt2/packagekit-qt2-config.cmake
/usr/lib/pkgconfig/packagekit-glib2.pc
/usr/lib/pkgconfig/packagekit-plugin.pc
/usr/lib/pkgconfig/packagekit-qt2.pc
/usr/share/gir-1.0/PackageKitGlib-1.0.gir
/usr/share/gir-1.0/PackageKitPlugin-1.0.gir

Changelog

2012-05-09 - Matthew Dawkins <mattydaw@mandriva.org> 0.7.4-2
+ Revision: 797669
- rebuild
- cleaned up spec (more could be done)
- moved gtk module files to gtk3-module pkg
- moved gir file to devel pkg
- added proper reqs for gir pkgs
2012-05-03 - Guilherme Moro <guilherme@mandriva.com> 0.7.4-1
+ Revision: 795710
- Updated to version 0.7.4
2011-11-11 - Z? <ze@mandriva.org> 0.6.20-2
+ Revision: 729936
- rename back to gtk-module
2011-11-11 - Z? <ze@mandriva.org> 0.6.20-1
+ Revision: 729920
- gtk3 support
- 0.6.20
2011-07-07 - Per ?yvind Karlsen <peroyvind@mandriva.org> 0.6.16-2
+ Revision: 689284
- enable suggests on packagekit-gtk-module now that we have font provides
2011-07-05 - Per ?yvind Karlsen <peroyvind@mandriva.org> 0.6.16-1
+ Revision: 688928
- new version
2011-05-25 - Funda Wang <fwang@mandriva.org> 0.6.14-4
+ Revision: 678968
- fix libexecdir in command-not-found script
- add more req
+ Per ?yvind Karlsen <peroyvind@mandriva.org>
- cosmetics
- drop legacy rpm stuff...
- move scriptlets for gstreamer-plugin subpackage to expected place in spec..
2011-05-24 - Per ?yvind Karlsen <peroyvind@mandriva.org> 0.6.14-3
+ Revision: 678195
- fix broken is_package_installed() in backport patch
2011-05-24 - Per ?yvind Karlsen <peroyvind@mandriva.org> 0.6.14-2
+ Revision: 678193
- fix build with glib 2.28.7 (P3)
- backport 'WhatProvides' & 'Cancel' features, 'Free' & 'Supported' filters (WIP)
- be sure to include and own directories under /var
2011-05-12 - Funda Wang <fwang@mandriva.org> 0.6.14-1
+ Revision: 673709
- add qt2 lib
- update to new version 0.6.14

See Also

Package Description
libpackagekit-glib14-0.7.6-7-rosa2012.1.i586.rpm Libraries for accessing PackageKit
libpackagekit-qt2_2-0.7.6-7-rosa2012.1.i586.rpm QT libraries for accessing PackageKit
libpackagekitglib-gir1.0-0.7.6-7-rosa2012.1.i586.rpm GObject Introspection interface library for packagekit glib
libpackagekitplugin-gir1.0-0.7.6-7-rosa2012.1.i586.rpm GObject Introspection interface library for packagekit plugin
libpala0-4.9.4-2-rosa2012.1.i586.rpm KDE 4 library
libpam-devel-1.1.4-9-rosa2012.1.i586.rpm Development headers and libraries for pam
libpam0-1.1.4-9-rosa2012.1.i586.rpm Library for pam
libpam_misc0-1.1.4-9-rosa2012.1.i586.rpm Library for pam
libpam_userpass-devel-1.0.2-8-rosa2012.1.i586.rpm Libraries and header files for developing pam_userpass-aware applications
libpam_userpass1-1.0.2-8-rosa2012.1.i586.rpm PAM module for USER/PASS-style protocols
libpamc0-1.1.4-9-rosa2012.1.i586.rpm Library for pam
libpanel-applet-2-devel-2.32.1-8-rosa2012.1.i586.rpm Static libraries, include files for GNOME panel
libpanel-applet-2_0-2.32.1-8-rosa2012.1.i586.rpm The core programs for the GNOME GUI desktop environment
libpanel-applet-3_0-2.32.1-8-rosa2012.1.i586.rpm The core programs for the GNOME GUI desktop environment
libpanel-applet-gir4.0-3.6.2-1-rosa2012.1.i586.rpm GObject Introspection interface description for gnome-panel
Advertisement
Advertisement