apache-mpm-rsbac-2.2.22-0.1-rosa.lts2012.0.x86_64.rpm


Advertisement

Description

apache-mpm-rsbac - Implements a non-threaded, pre-forking web server with RSABC patch (stable)

Distribution: ROSA Enterprise Desktop
Repository: ROSA Contrib Updates x86_64
Package name: apache-mpm-rsbac
Package version: 2.2.22
Package release: 0.1-rosa.lts2012.0
Package architecture: x86_64
Package type: rpm
Installed size: 622.92 KB
Download size: 219.03 KB
Official Mirror: mirror.rosalab.ru
This Multi-Processing Module (MPM) implements a non-threaded, pre-forking web server that handles requests in a manner similar to Apache 1.3. It is appropriate for sites that need to avoid threading for compatibility with non-thread-safe libraries. It is also the best MPM for isolating each request, so that a problem with a single request will not affect any other. This MPM contain the RSBAC support but the extra features is the mod_rsbac packages. You see a more information is mod_rsbac package. mpm-rsbac is based on the traditional prefork MPM, which means it's non-threaded; in short, this means you can run non-thread-aware code (like many PHP extensions) without problems. (On the other hand, you lose out to any performance benefit you'd get with threads, of course; you'd have to decide for yourself if that's worth it or not.) This MPM is very self-regulating, so it is rarely necessary to adjust its configuration directives. Most important is that MaxClients be big enough to handle as many simultaneous requests as you expect to receive, but small enough to assure that there is enough physical RAM for all processes. Check for available Apache modules here: http://nux.se/apache/ This package defaults to a maximum of 128 dynamically loadable modules. This package defaults to a ServerLimit of 1024. You can change these values at RPM build time by using for example: --define 'maxmodules 512' --define 'serverlimit 2048' The package was built to support a maximum of 128 dynamically loadable modules. The package was built with a ServerLimit of 1024. I M P O R T A N T ----------------- This package is only to the RSBAC enabled kernels and may not be stable or suitable at any time, in any way, or for any kind production usage. Be warned. You must manually add HTTPD="/usr/sbin/httpd-rsbac" in the /etc/sysconfig/httpd configuration file to be able to use this MPM.

Alternatives

Provides

  • apache == 2.2.22-0.1
  • apache-mpm == 2.2.22-0.1
  • apache-mpm-rsbac == 2.2.22-0.1:2012.0
  • webserver

    Install Howto

    1. Enable ROSA Contrib Updates repository on Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install apache-mpm-rsbac rpm package:
      # urpmi apache-mpm-rsbac

    Files

    • /usr/sbin/httpd-rsbac
    • /usr/share/doc/apache-mpm-rsbac/httpd-2.2.22-rsbac.patch
    • /usr/share/doc/apache-mpm-rsbac/httpd-autoindex.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd-dav.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd-default.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd-info.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd-languages.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd-manual.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd-mpm.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd-multilang-errordoc.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd-ssl.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd-userdir.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd-vhosts.conf
    • /usr/share/doc/apache-mpm-rsbac/httpd.conf

    Changelog

    2012-02-07 - Lonyai Gergely <aleph@mandriva.org> 2.2.22-0.1mdv2011.0 + Revision: 771673 - Update the rsbac patch to 2.2.22 - 2.2.22-0.1 - rebuild - 2.2.21-0.32.2.21-0.32.2.21-0.3 - 2.2.21-0.2 - 2.2.21-0.1 - 2.2.19-1

    2011-05-15 - Lonyai Gergely <aleph@mandriva.org> 2.2.18-1 + Revision: 674773 - 2.2.18-1

    2011-03-31 - Lonyai Gergely <aleph@mandriva.org> 2.2.17-7 + Revision: 649505 - rebuild to official apache

    2011-03-01 - Lonyai Gergely <aleph@mandriva.org> 2.2.17-6 + Revision: 641101 - 2.2.17-6

    2011-01-03 - Oden Eriksson <oeriksson@mandriva.com> 2.2.17-4mdv2011.0 + Revision: 627742 - don't force the usage of automake1.7

    2010-12-03 - Lonyai Gergely <aleph@mandriva.org> 2.2.17-3mdv2011.0 + Revision: 606559 - 2.2.17-3 + Paulo Andrade <pcpa@mandriva.com.br> - Rebuild with apr with workaround to issue with gcc type based

    2010-10-18 - Lonyai Gergely <aleph@mandriva.org> 2.2.17-0.0.pre.1mdv2011.0 + Revision: 586578 - 2.2.17-0.0.pre1

    2010-08-11 - Lonyai Gergely <aleph@mandriva.org> 2.2.16-1mdv2011.0 + Revision: 569036 - 2.2.16-1

    2010-04-27 - Lonyai Gergely <aleph@mandriva.org> 2.2.15-3mdv2010.1 + Revision: 539632 - 2.2.15-3mdv2010.1

    2010-04-01 - Lonyai Gergely <aleph@mandriva.org> 2.2.15-2mdv2010.1 + Revision: 530621 - rebuild

    Advertisement
    Advertisement