rubygem-launchy-0.3.7-1-rosa.lts2012.0.noarch.rpm


Advertisement

Description

rubygem-launchy - Helper class for launching cross-platform applications

Property Value
Distribution ROSA Enterprise Desktop
Repository ROSA Contrib Updates x86_64
Package name rubygem-launchy
Package version 0.3.7
Package release 1-rosa.lts2012.0
Package architecture noarch
Package type rpm
Installed size 287.69 KB
Download size 56.33 KB
Official Mirror mirror.rosalab.ru
Launchy is helper class for launching cross-platform applications in a
fire and forget manner.
There are application concepts (browser, email client, etc) that are
common across all platforms, and they may be launched differently on
each platform.  Launchy is here to make a common approach to launching
external application from within ruby programs.

Alternatives

Package Version Architecture Repository
rubygem-launchy-0.3.7-1-rosa.lts2012.0.noarch.rpm 0.3.7 noarch ROSA Contrib Updates
rubygem-launchy - - -

Requires

Name Value
coreutils -
ruby -
ruby(abi) == 1.8
rubygem(configuration) >= 0.0.5
rubygem(rake) >= 0.8.1
rubygems -

Provides

Name Value
rubygem(launchy) == 0.3.7
rubygem-launchy == 0.3.7-1:2012.0

Download

Type URL
Binary Package rubygem-launchy-0.3.7-1-rosa.lts2012.0.noarch.rpm
Source Package rubygem-launchy-0.3.7-1.src.rpm

Install Howto

  1. Enable ROSA Contrib Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install rubygem-launchy rpm package:
    # urpmi rubygem-launchy

Files

Path
/usr/bin/launchy
/usr/lib/ruby/gems/1.8/cache/launchy-0.3.7.gem
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/created.rid
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/fr_class_index.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/fr_file_index.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/fr_method_index.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/index.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/rdoc-style.css
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/classes/Launchy.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/classes/Launchy/Application.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/classes/Launchy/Browser.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/classes/Launchy/CommandLine.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/classes/Launchy/Paths.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/classes/Launchy/Version.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/files/HISTORY.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/files/LICENSE.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/files/README.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/files/lib/launchy_rb.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/files/lib/launchy/application_rb.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/files/lib/launchy/browser_rb.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/files/lib/launchy/command_line_rb.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/files/lib/launchy/paths_rb.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/rdoc/files/lib/launchy/version_rb.html
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/created.rid
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/cdesc-Launchy.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/command_line-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/log-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/open-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/require_all_libs_relative_to-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/app_list-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/application_classes-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/cdesc-Application.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/cygwin_app_list-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/darwin_app_list-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/find_application_class_for-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/find_executable-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/find_executable-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/inherited-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/known_os_families-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/my_os-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/my_os-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/my_os_family-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/my_os_family-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/nix_desktop_environment-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/run-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/testing_app_list-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Application/windows_app_list-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/browser-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/cdesc-Browser.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/desktop_environment_browser_launchers-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/desktop_environment_browser_launchers-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/fallback_browsers-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/fallback_browsers-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/handle%3f-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/new-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/nix_app_list-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/run-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Browser/visit-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/CommandLine/cdesc-CommandLine.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/CommandLine/parser-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/CommandLine/run-i.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Paths/cdesc-Paths.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Paths/lib_path-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Paths/root_dir-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Paths/sub_path-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Version/cdesc-Version.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Version/to_a-c.yaml
/usr/lib/ruby/gems/1.8/doc/launchy-0.3.7/ri/Launchy/Version/to_s-c.yaml
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/HISTORY
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/LICENSE
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/README
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/Rakefile
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/gemspec.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/bin/launchy
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/lib/launchy.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/lib/launchy/application.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/lib/launchy/browser.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/lib/launchy/command_line.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/lib/launchy/paths.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/lib/launchy/version.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/spec/application_spec.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/spec/browser_spec.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/spec/launchy_spec.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/spec/paths_spec.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/spec/spec_helper.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/spec/tattle-host-os.yml
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/spec/version_spec.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/tasks/announce.rake
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/tasks/config.rb
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/tasks/distribution.rake
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/tasks/documentation.rake
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/tasks/rspec.rake
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/tasks/rubyforge.rake
/usr/lib/ruby/gems/1.8/gems/launchy-0.3.7/tasks/utils.rb
/usr/lib/ruby/gems/1.8/specifications/launchy-0.3.7.gemspec

Changelog

2010-11-03 - R?my Clouard <shikamaru@mandriva.org> 0.3.7-1mdv2011.0
+ Revision: 592972
- import rubygem-launchy

See Also

Package Description
rubygem-linecache-0.43-2-rosa.lts2012.0.x86_64.rpm Read file with caching
rubygem-maruku-0.5.9-1-rosa.lts2012.0.noarch.rpm Maruku is a Markdown-superset interpreter written in Ruby
rubygem-memcache-client-1.8.5-1-rosa.lts2012.0.noarch.rpm A Ruby library for accessing memcached
rubygem-mime-types-1.16-4-rosa.lts2012.0.noarch.rpm MIME content type identification library for ruby
rubygem-minitest-1.7.1-2-rosa.lts2012.0.noarch.rpm A small and fast replacement for ruby's huge and slow test/unit
rubygem-mocha-0.9.10-1-rosa.lts2012.0.noarch.rpm Mocking and stubbing library
rubygem-multi_json-0.0.4-1-rosa.lts2012.0.noarch.rpm A gem to provide swappable JSON backends
rubygem-mustache-0.11.2-1-rosa.lts2012.0.noarch.rpm Mustache is a framework-agnostic way to render logic-free views
rubygem-nokogiri-1.4.3.1-1-rosa.lts2012.0.x86_64.rpm A HTML, XML, SAX, and Reader parser written in ruby
rubygem-oa-core-0.0.5-1-rosa.lts2012.0.noarch.rpm HTTP Basic strategies for OmniAuth
rubygem-oa-oauth-0.0.1-1-rosa.lts2012.0.noarch.rpm OAuth strategies for OmniAuth
rubygem-oauth-0.4.4-1-rosa.lts2012.0.noarch.rpm OAuth Core Ruby implementation
rubygem-oauth-doc-0.4.4-1-rosa.lts2012.0.noarch.rpm Documentation for rubygem-oauth
rubygem-oauth2-0.0.13-1-rosa.lts2012.0.noarch.rpm A Ruby wrapper for the OAuth 2.0 protocol
rubygem-oniguruma-1.1.0-2-rosa.lts2012.0.x86_64.rpm Ruby bindings for the Onigurama regexp library
Advertisement
Advertisement