libffmpeg-devel-0.7.11-6-rosa.lts2012.0.i586.rpm


Advertisement

Description

libffmpeg-devel - Header files for the ffmpeg codec library

Property Value
Distribution ROSA Enterprise Desktop
Repository ROSA Main i586
Package name libffmpeg-devel
Package version 0.7.11
Package release 6-rosa.lts2012.0
Package architecture i586
Package type rpm
Installed size 470.07 KB
Download size 105.34 KB
Official Mirror mirror.rosalab.ru
ffmpeg is a hyper fast realtime audio/video encoder, a streaming  server
and a generic audio and video file converter.
It can grab from a standard Video4Linux video source and convert it into
several file formats based on DCT/motion compensation encoding. Sound is
compressed in MPEG audio layer 2 or using an AC3 compatible stream.
Install libffmpeg-devel if you want to compile apps with ffmpeg support.

Alternatives

Package Version Architecture Repository
libffmpeg-devel-0.7.12-1plf-plf2012.0.i586.rpm 0.7.12 i586 ROSA Restricted Updates
libffmpeg-devel-0.7.12-1-rosa.lts2012.0.i586.rpm 0.7.12 i586 ROSA Main Updates
libffmpeg-devel-0.7.11-6plf-plf2012.0.i586.rpm 0.7.11 i586 ROSA Restricted
libffmpeg-devel - - -

Requires

Name Value
devel(libSDL-1.2) -
devel(libX11) -
devel(libXext) -
devel(libXfixes) -
devel(libasound) -
devel(libavcodec) -
devel(libavformat) -
devel(libavutil) -
devel(libbz2) -
devel(libdc1394) -
devel(libjack) -
devel(libm) -
devel(librtmp) -
devel(libschroedinger-1.0) -
devel(libswscale) -
devel(libtheoradec) -
devel(libtheoraenc) -
devel(libva) -
devel(libvorbis) -
devel(libvorbisenc) -
devel(libvpx) -
devel(libz) -
libavfilter1 == 0.7.11-6
libavformats52 == 0.7.11-6
libavutil50 == 0.7.11-6
libffmpeg52 == 0.7.11-6
libpostproc51 == 0.7.11-6
libswscaler0 == 0.7.11-6
pkgconfig -

Provides

Name Value
devel(libavcodec) -
devel(libavdevice) -
devel(libavfilter) -
devel(libavformat) -
devel(libavutil) -
devel(libpostproc) -
devel(libswscale) -
ffmpeg-devel == 0.7.11-6
libffmpeg-devel == 0.7.11-6
libffmpeg-devel == 0.7.11-6:2012.0
pkgconfig(libavcodec) == 52.123.0
pkgconfig(libavdevice) == 52.5.0
pkgconfig(libavfilter) == 1.80.0
pkgconfig(libavformat) == 52.111.0
pkgconfig(libavutil) == 50.43.0
pkgconfig(libpostproc) == 51.2.0
pkgconfig(libswscale) == 0.14.1

Obsoletes

Name Value
libffmpeg51-devel -

Download

Type URL
Binary Package libffmpeg-devel-0.7.11-6-rosa.lts2012.0.i586.rpm
Source Package ffmpeg-0.7.11-6.src.rpm

Install Howto

  1. Enable ROSA Main repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libffmpeg-devel rpm package:
    # urpmi libffmpeg-devel

Files

Path
/usr/include/libavcodec/avcodec.h
/usr/include/libavcodec/avfft.h
/usr/include/libavcodec/dxva2.h
/usr/include/libavcodec/opt.h
/usr/include/libavcodec/vaapi.h
/usr/include/libavcodec/vdpau.h
/usr/include/libavcodec/version.h
/usr/include/libavcodec/xvmc.h
/usr/include/libavdevice/avdevice.h
/usr/include/libavfilter/avcodec.h
/usr/include/libavfilter/avfilter.h
/usr/include/libavfilter/avfiltergraph.h
/usr/include/libavfilter/vsink_buffer.h
/usr/include/libavfilter/vsrc_buffer.h
/usr/include/libavformat/avformat.h
/usr/include/libavformat/avio.h
/usr/include/libavformat/version.h
/usr/include/libavutil/adler32.h
/usr/include/libavutil/aes.h
/usr/include/libavutil/attributes.h
/usr/include/libavutil/audioconvert.h
/usr/include/libavutil/avassert.h
/usr/include/libavutil/avconfig.h
/usr/include/libavutil/avstring.h
/usr/include/libavutil/avutil.h
/usr/include/libavutil/base64.h
/usr/include/libavutil/bswap.h
/usr/include/libavutil/common.h
/usr/include/libavutil/cpu.h
/usr/include/libavutil/crc.h
/usr/include/libavutil/dict.h
/usr/include/libavutil/error.h
/usr/include/libavutil/eval.h
/usr/include/libavutil/fifo.h
/usr/include/libavutil/file.h
/usr/include/libavutil/imgutils.h
/usr/include/libavutil/intfloat_readwrite.h
/usr/include/libavutil/intreadwrite.h
/usr/include/libavutil/lfg.h
/usr/include/libavutil/log.h
/usr/include/libavutil/lzo.h
/usr/include/libavutil/mathematics.h
/usr/include/libavutil/md5.h
/usr/include/libavutil/mem.h
/usr/include/libavutil/opt.h
/usr/include/libavutil/parseutils.h
/usr/include/libavutil/pixdesc.h
/usr/include/libavutil/pixfmt.h
/usr/include/libavutil/random_seed.h
/usr/include/libavutil/rational.h
/usr/include/libavutil/samplefmt.h
/usr/include/libavutil/sha.h
/usr/include/libavutil/sha1.h
/usr/include/libpostproc/postprocess.h
/usr/include/libswscale/swscale.h
/usr/lib/libavcodec.so
/usr/lib/libavdevice.so
/usr/lib/libavfilter.so
/usr/lib/libavformat.so
/usr/lib/libavutil.so
/usr/lib/libpostproc.so
/usr/lib/libswscale.so
/usr/lib/pkgconfig/libavcodec.pc
/usr/lib/pkgconfig/libavdevice.pc
/usr/lib/pkgconfig/libavfilter.pc
/usr/lib/pkgconfig/libavformat.pc
/usr/lib/pkgconfig/libavutil.pc
/usr/lib/pkgconfig/libpostproc.pc
/usr/lib/pkgconfig/libswscale.pc

Changelog

2011-11-22 - G?tz Waschk <waschk@mandriva.org> 0.7.8-1mdv2011.0
+ Revision: 732684
- new version
- bump x264 dep
- remove obsolete faad option
- rebuild
- build with librtmp (bug #60225)
- rebuild for new libva
- new version 0.6
- drop patch 2
- build with vp8 support
- disable internal vorbis encoder (bug #59797)
- disable AAC decoder and encoder
- rebuild
- new snapshot
- drop patch 2
- bump x264 dep
- add more deps to the main package (gc)
- new snapshot
- fix x264 build
- bump x264 dep
- new snapshot
- drop imgresample patch, the old API is now gone
- new major
- replace amr by openamr
- disable faac support
- update build deps
- update license
- fix source URL
- new version
- new snapshot
- rediff patch 0
- new snapshot
- rediff patch 0
- drop patch 2
- disable parallel build
- rediff the patch again
- new snapshot
- fix format strings
- update file list
- new snapshot
- explicit dep on libpostproc to fix upgrades
- spec cleanup
- bump x264 dep
- new snapshot
- add conflict with old ffmpeg package to libpostproc
- new snapshot
- new major
- split out libpostproc
- changes recommended upstream:
* disable external libnut support
* drop liba52dec, xvid
- new snapshot
- remove mpegaudio.h again
- new snapshot
- update patch 0
- add missing headers requested in bug #41949
- new snapshot
- reenable deprecated libavcodec image scaler for vlc
- bump for build system trouble
- new snapshot
- reenable swscaler
- fix header file conflict
- new version
- drop dirac support
- fix build
- update file list
- update license tag
- disable amr_nb and amr_wb in PLF, it would make the build undistributable
- enable vorbis and theora
- new version
- update dirac deps
- update dirac patch
- fix pkgconfig file generated by dirac patch
- new version
- fix versioned deps between the packages, the important part is the release
- new version
- bump avformat major
- add libavdevice
- rediff patch 3
- new version
- drop patch 0
- fix dirac patch to correctly generate the pkgconfig files
- new devel name
- fix configure options
- new version
- patch0: build fix
- update dirac patch
- update deps
- new version
- patch for dirac support
- fix buildrequires
- drop merged patch 2
- drop amr source, support using external libamrnb instead
+ Funda Wang <fwang@mandriva.org>
- br yasm
- new versinon 0.7.1
- new version 0.6.3
- update br
- rebuild
- new version 0.6.1
- add BR for more encoders
+ Anssi Hannula <anssi@mandriva.org>
- plf: append "plf" to Release on cooker to make plf build have higher EVR
again with the rpm5-style mkrel now in use
- build with vaapi support
- fix debug packages (stripping happened too early)
- fix a regression causing wrong fourcc selection for VP6F remuxing
(ffmpeg-move-vp6f-up.patch)
- build with vdpau support on 2009.0+ (BR vdpau-devel)
- build_amr option (disabled by default) needs --enable-nonfree
- update reenable-imgresample.patch so that duplicate sws_ symbols are
omitted from libavcodec (from Debian adaptation of the patch)
- drop now unneeded ffplay-uses-xlib.patch (ffplay only uses SDL)
- set --incdir explicitely so that pkg-config files get generated
correctly
- use --shlibdir instead of move hack for lib64
- fix pkgconfig requires for dirac
+ Emmanuel Andry <eandry@mandriva.org>
- enable cpu detection at run time
- enable schroedinger and firewire support
- New svn snapshot
- New svn snapshot
- New svn snapshot
+ Oden Eriksson <oeriksson@mandriva.com>
- new url
- rediffed one fuzzy patch
- use %%ldflags and fix linkage (P1)
+ Christophe Fergeau <cfergeau@mandriva.com>
- rebuild
+ Pixel <pixel@mandriva.com>
- do not call ldconfig in %%post/%%postun, it is now handled by filetriggers
+ Olivier Blin <blino@mandriva.org>
- restore BuildRoot
+ Thierry Vignaud <tv@mandriva.org>
- build with -fPIC (#35955)
- kill re-definition of %%buildroot on Pixel's request

See Also

Package Description
libffmpeg-static-devel-0.7.11-6-rosa.lts2012.0.i586.rpm Static library for the ffmpeg codec library
libffmpeg52-0.7.11-6-rosa.lts2012.0.i586.rpm Shared library part of ffmpeg
libfftw-devel-3.2.2-6-rosa.lts2012.0.i586.rpm Headers, libraries, & docs for FFTW fast fourier transform library
libfftw2-2.1.5-15-rosa.lts2012.0.i586.rpm Fast fourier transform library
libfftw2-devel-2.1.5-15-rosa.lts2012.0.i586.rpm Headers, libraries, & docs for FFTW fast fourier transform library
libfftw3-3.2.2-6-rosa.lts2012.0.i586.rpm Fast fourier transform library
libfinch0-2.10.2-0.1-rosa.lts2012.0.i586.rpm The libgnt library for the Finch IM client
libflac++-devel-1.2.1-12-rosa.lts2012.0.i586.rpm Libraries and headers needed for building apps using FLAC++
libflac++6-1.2.1-12-rosa.lts2012.0.i586.rpm Shared C++ libraries for FLAC
libflac-devel-1.2.1-12-rosa.lts2012.0.i586.rpm Libraries and headers needed for building apps using FLAC
libflac8-1.2.1-12-rosa.lts2012.0.i586.rpm Shared libraries for FLAC
libfli-devel-1.7-5-rosa.lts2012.0.i586.rpm Devel stuff for libfli
libfli1-1.7-5-rosa.lts2012.0.i586.rpm libfli library
libfltk-devel-1.1.10-9-rosa.lts2012.0.i586.rpm Fast Light Tool Kit (FLTK) - development environment
libfltk1.1-1.1.10-9-rosa.lts2012.0.i586.rpm Fast Light Tool Kit (FLTK) - main library
Advertisement
Advertisement