lib64qtcore4-4.8.3-4-rosa.lts2012.0.x86_64.rpm


Advertisement

Description

lib64qtcore4 - Qt4 Component Library

Property Value
Distribution ROSA Enterprise Desktop
Repository ROSA Main Updates x86_64
Package name lib64qtcore4
Package version 4.8.3
Package release 4-rosa.lts2012.0
Package architecture x86_64
Package type rpm
Installed size 3.35 MB
Download size 1.15 MB
Official Mirror mirror.rosalab.ru
Qt component library.

Alternatives

Package Version Architecture Repository
lib64qtcore4-4.8.0-8-rosa.lts2012.0.x86_64.rpm 4.8.0 x86_64 ROSA Main
lib64qtcore4 - - -

Requires

Name Value
ld-linux-x86-64.so.2()(64bit) -
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) -
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libc.so.6(GLIBC_2.9)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libglib-2.0.so.0()(64bit) -
libgthread-2.0.so.0()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libz.so.1()(64bit) -

Provides

Name Value
elf(buildid) == 647df0d32d5b29d0eb89e63be4c330902620b6de
elf(buildid) == 750d4dad74989f051b5b711e8274607956378adb
elf(buildid) == b3c40168e3437f7b66f62025e7dacb6afd263121
elf(buildid) == d6b19ac7e95c24ddf783dc357c71f8be3ecf3cdc
elf(buildid) == e7adaa05d9c745cf1c4e9ed6df2539ac3a641b7f
lib64qtcore4 == 4:4.8.3-4:2012.0
libQtCore.so.4()(64bit) -
libqcncodecs.so()(64bit) -
libqjpcodecs.so()(64bit) -
libqkrcodecs.so()(64bit) -
libqtwcodecs.so()(64bit) -

Conflicts

Name Value
lib64qtgui4 <= 2:4.2.2

Obsoletes

Name Value
lib64qtuitools4 -
qt4-codecs-plugin-lib64 -

Download

Type URL
Binary Package lib64qtcore4-4.8.3-4-rosa.lts2012.0.x86_64.rpm
Source Package qt4-4.8.3-4.src.rpm

Install Howto

  1. Enable ROSA Main Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64qtcore4 rpm package:
    # urpmi lib64qtcore4

Files

Path
/usr/lib64/libQtCore.so.4
/usr/lib64/libQtCore.so.4.8
/usr/lib64/libQtCore.so.4.8.3
/usr/lib64/qt4/plugins/codecs/libqcncodecs.so
/usr/lib64/qt4/plugins/codecs/libqjpcodecs.so
/usr/lib64/qt4/plugins/codecs/libqkrcodecs.so
/usr/lib64/qt4/plugins/codecs/libqtwcodecs.so

Changelog

2012-07-04 - Bernhard Rosenkraenzer <bero@bero.eu> 4:4.8.2-1
+ Revision: 808014
- Link with gold
- Build in stdc++11 mode to get support for ISO C++11 list constructors etc.
- Fix rpmlint errors
+ Franck Bui <franck.bui@mandriva.com>
- Don't install demos/ and examples/ dirs if not needed
+ Andrey Bondrov <abondrov@mandriva.org>
- Drop qt48setx patch (applied in upstream)
- New version 4.8.2, re-diff fix-qvfb-build patch
2012-04-19 - Bernhard Rosenkraenzer <bero@bero.eu> 4:4.8.1-2
+ Revision: 791865
- Add fix for QTextLayout::cursorToX() crash from Calligra
2012-03-29 - Andrey Bondrov <abondrov@mandriva.org> 4:4.8.1-1
+ Revision: 788081
- Also drop already not used patches 0, 1 and 5
- New version 4.8.1, drop no longer needed patches 2, 4 and 11
2012-03-26 - Andrey Bondrov <abondrov@mandriva.org> 4:4.8.0-8
+ Revision: 787014
- Add pkgconfig(xinerama) to BuildRequires
- Add -xinerama and -xrandr to configure options to fix twinview multi-monitor support in KDE4 4.8
2012-03-23 - Per ?yvind Karlsen <peroyvind@mandriva.org> 4:4.8.0-7
+ Revision: 786255
- get rid of extra '/', which will make their way into pkg-config files, with
'//' in path names, which again will break debugedit with the following error:
"'canonicalization unexpectedly shrank by one character"
+ Andrey Bondrov <abondrov@mandriva.org>
- Add patch 11 from upstream to deal with KDE4 bug 275469
- Fix file list: libqvggraphicssystem.so is built only when openvg is enabled
2012-01-26 - Andrey Bondrov <abondrov@mandriva.org> 4:4.8.0-5
+ Revision: 769156
- Add rsync to BuildRequires as it's no longer installed by default
- Fix BR (Mesa-common-devel -> mesa-common-devel)
- Replace spaces with tabs where it's needed, fix BR (mesaopenvg-devel -> pkgconfig(vg))
- Add qt4-devel-private subpackage needed for qt-creator update
+ Z? <ze@mandriva.org>
- seams chroots are already updated, thus clean this ugly hack
2011-12-28 - Z? <ze@mandriva.org> 4:4.8.0-4
+ Revision: 745868
- ugly hack needed untill rpm5 gets fixed
- link instead copy same files
- own inputmethods folder
- fix old macros in scriptlets
- list files (since some are conditional) in devel package
- give some order how packages sorted
2011-12-22 - Oden Eriksson <oeriksson@mandriva.com> 4:4.8.0-3
+ Revision: 744413
- rebuilt against libtiff.so.5
2011-12-22 - Z? <ze@mandriva.org> 4:4.8.0-2
+ Revision: 744293
- bump release to package changes
- remove remaining requires and provides from libs
- add conditional in remaining webkit stuff
- add provide in devel package for qt without soversion
- add conflcit due to file move
- no need to include soversion in qt macros names
- add missing requires in designer package
- fix examples group
- move qdeclarativeview plugin (isnt qml related)
- fix summary and description in libqtdeclarative package
- some minor adjusts in summaries
- adjust remaining webkit stuff
- fix some descriptions

See Also

Package Description
lib64qtdbus4-4.8.3-4-rosa.lts2012.0.x86_64.rpm Qt4 DBus Library
lib64qtdeclarative4-4.8.3-4-rosa.lts2012.0.x86_64.rpm Qt4 Multimedia Library
lib64qtdesigner4-4.8.3-4-rosa.lts2012.0.x86_64.rpm Qt4 Component Library
lib64qtfeedback1-1.2.2-2-rosa.lts2012.0.x86_64.rpm Qt Mobility Framework library
lib64qtgallery1-1.2.2-2-rosa.lts2012.0.x86_64.rpm Qt Mobility Framework library
lib64qtgui4-4.8.3-4-rosa.lts2012.0.x86_64.rpm Qt4 Component Library
lib64qthelp4-4.8.3-4-rosa.lts2012.0.x86_64.rpm Qt4 Component Library
lib64qtlocation1-1.2.2-2-rosa.lts2012.0.x86_64.rpm Qt Mobility Framework library
lib64qtmultimedia4-4.8.3-4-rosa.lts2012.0.x86_64.rpm Qt4 Multimedia Library
lib64qtmultimediakit1-1.2.2-2-rosa.lts2012.0.x86_64.rpm Qt Mobility Framework library
lib64qtnetwork4-4.8.3-4-rosa.lts2012.0.x86_64.rpm Qt4 Component Library
lib64qtopengl4-4.8.3-4-rosa.lts2012.0.x86_64.rpm Qt4 Component Library
lib64qtorganizer1-1.2.2-2-rosa.lts2012.0.x86_64.rpm Qt Mobility Framework library
lib64qtpublishsubscribe1-1.2.2-2-rosa.lts2012.0.x86_64.rpm Qt Mobility Framework library
lib64qtruby4shared2-4.8.3-1-rosa.lts2012.0.x86_64.rpm Qt generic bindings library
Advertisement
Advertisement