lib64gjs-devel-1.40.1-3-rosa2014.1.x86_64.rpm


Advertisement

Description

lib64gjs-devel - JavaScript bindings based on gobject-introspection

Property Value
Distribution ROSA 2014.1
Repository ROSA Main x86_64
Package name lib64gjs-devel
Package version 1.40.1
Package release 3-rosa2014.1
Package architecture x86_64
Package type rpm
Installed size 94.59 KB
Download size 18.81 KB
Official Mirror mirror.rosalab.ru
This package contains JavaScript bindings based on gobject-introspection.

Alternatives

Package Version Architecture Repository
lib64gjs-devel-1.43.3-2-rosa2014.1.x86_64.rpm 1.43.3 x86_64 ROSA Main Updates
lib64gjs-devel - - -

Requires

Name Value
devel(libcairo(64bit)) -
devel(libcairo-gobject(64bit)) -
devel(libffi(64bit)) -
devel(libgcc_s(64bit)) -
devel(libgio-2.0(64bit)) -
devel(libgirepository-1.0(64bit)) -
devel(libglib-2.0(64bit)) -
devel(libgobject-2.0(64bit)) -
devel(libmozjs-24(64bit)) -
devel(libstdc++(64bit)) -
lib64gjs-gir1.0 == 1.40.1-3
lib64gjs0 == 1.40.1-3
pkgconfig(gobject-2.0) -
pkgconfig(gobject-introspection-1.0) -
pkgconfig(mozjs-24) -

Provides

Name Value
devel(libgjs(64bit)) -
gjs-devel == 1.40.1-3
lib64gjs-devel == 1.40.1-3:2014.1
pkgconfig(gjs-1.0) == 1.40.1
pkgconfig(gjs-internals-1.0) == 1.40.1

Download

Type URL
Binary Package lib64gjs-devel-1.40.1-3-rosa2014.1.x86_64.rpm
Source Package gjs-1.40.1-3.src.rpm

Install Howto

  1. Enable ROSA Main repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install lib64gjs-devel rpm package:
    # urpmi lib64gjs-devel

Files

Path
/usr/include/gjs-1.0/
/usr/include/gjs-1.0/gi/arg.h
/usr/include/gjs-1.0/gi/boxed.h
/usr/include/gjs-1.0/gi/closure.h
/usr/include/gjs-1.0/gi/enumeration.h
/usr/include/gjs-1.0/gi/foreign.h
/usr/include/gjs-1.0/gi/function.h
/usr/include/gjs-1.0/gi/fundamental.h
/usr/include/gjs-1.0/gi/gerror.h
/usr/include/gjs-1.0/gi/gtype.h
/usr/include/gjs-1.0/gi/interface.h
/usr/include/gjs-1.0/gi/keep-alive.h
/usr/include/gjs-1.0/gi/ns.h
/usr/include/gjs-1.0/gi/object.h
/usr/include/gjs-1.0/gi/param.h
/usr/include/gjs-1.0/gi/repo.h
/usr/include/gjs-1.0/gi/union.h
/usr/include/gjs-1.0/gi/value.h
/usr/include/gjs-1.0/gjs/byteArray.h
/usr/include/gjs-1.0/gjs/compat.h
/usr/include/gjs-1.0/gjs/context.h
/usr/include/gjs-1.0/gjs/coverage.h
/usr/include/gjs-1.0/gjs/gjs-module.h
/usr/include/gjs-1.0/gjs/gjs.h
/usr/include/gjs-1.0/gjs/importer.h
/usr/include/gjs-1.0/gjs/jsapi-util.h
/usr/include/gjs-1.0/gjs/mem.h
/usr/include/gjs-1.0/gjs/native.h
/usr/include/gjs-1.0/gjs/runtime.h
/usr/include/gjs-1.0/gjs/type-module.h
/usr/lib64/libgjs.so
/usr/lib64/pkgconfig/gjs-1.0.pc
/usr/lib64/pkgconfig/gjs-internals-1.0.pc

Changelog

2014-06-27 - Alex Burmashev <alex.burmashev@rosalab.ru> 1.40.1-3
+ Revision: b8a5ec1
- MassBuild#440: Increase release tag

See Also

Package Description
lib64gjs-gir1.0-1.40.1-3-rosa2014.1.x86_64.rpm GObject Introspection interface description for gjs
lib64gjs0-1.40.1-3-rosa2014.1.x86_64.rpm JavaScript bindings based on gobject-introspection
lib64gksu2.0_0-2.0.12-7-rosa2014.1.x86_64.rpm GKSu libraries
lib64gksu2.0_0-devel-2.0.12-7-rosa2014.1.x86_64.rpm Development package for libgksu
lib64gl-devel-10.2.7-3-rosa2014.1.x86_64.rpm Development files for Mesa (OpenGL compatible 3D lib)
lib64gl1-10.2.7-3-rosa2014.1.x86_64.rpm Files for Mesa (GL and GLX libs)
lib64gl2ps-devel-1.3.8-4-rosa2014.1.x86_64.rpm Header files for GL2PS library
lib64gl2ps1-1.3.8-4-rosa2014.1.x86_64.rpm An OpenGL to PostScript printing library
lib64glade2.0-devel-2.6.4-10-rosa2014.1.x86_64.rpm Libraries, includes, etc to develop libglade applications
lib64glade2.0_0-2.6.4-10-rosa2014.1.x86_64.rpm Library for dynamically loading GLADE interface files
lib64glademm2.4-devel-2.6.7-8-rosa2014.1.x86_64.rpm Development related files of libglademm
lib64glademm2.4_1-2.6.7-8-rosa2014.1.x86_64.rpm C++ interface of glade2 library
lib64gladeui-gir2.0-3.18.3-2-rosa2014.1.x86_64.rpm GObject Introspection interface description for libgladeui (glade)
lib64gladeui1-devel-3.8.5-2-rosa2014.1.x86_64.rpm Development libraries, include files for libgladeui (glade-3)
lib64gladeui1_11-3.8.5-2-rosa2014.1.x86_64.rpm Libraries required for glade-3
Advertisement
Advertisement