perl-Dist-CheckConflicts-0.110.0-2-rosa2014.1.noarch.rpm


Advertisement

Description

perl-Dist-CheckConflicts - Declare version conflicts for your dist

Property Value
Distribution ROSA 2014.1
Repository ROSA Main x86_64
Package name perl-Dist-CheckConflicts
Package version 0.110.0
Package release 2-rosa2014.1
Package architecture noarch
Package type rpm
Installed size 56.00 KB
Download size 21.88 KB
Official Mirror mirror.rosalab.ru
One shortcoming of the CPAN clients that currently exist is that they have
no way of specifying conflicting downstream dependencies of modules. This
module attempts to work around this issue by allowing you to specify
conflicting versions of modules separately, and deal with them after the
module is done installing.
For instance, say you have a module 'Foo', and some other module 'Bar' uses
'Foo'. If 'Foo' were to change its API in a non-backwards-compatible way,
this would cause 'Bar' to break until it is updated to use the new API.
'Foo' can't just depend on the fixed version of 'Bar', because this will
cause a circular dependency (because 'Bar' is already depending on 'Foo'),
and this doesn't express intent properly anyway - 'Foo' doesn't use 'Bar'
at all. The ideal solution would be for there to be a way to specify
conflicting versions of modules in a way that would let CPAN clients update
conflicting modules automatically after an existing module is upgraded, but
until that happens, this module will allow users to do this manually.
This module accepts a hash of options passed to its 'use' statement, with
these keys being valid:

Alternatives

Package Version Architecture Repository
perl-Dist-CheckConflicts-0.110.0-2-rosa2014.1.noarch.rpm 0.110.0 noarch ROSA Main
perl-Dist-CheckConflicts - - -

Requires

Name Value
perl(Carp) -
perl(Exporter) -
perl(Module::Runtime) >= 0.9.0
perl(abi) >= 5.18.2

Provides

Name Value
perl(Dist::CheckConflicts) == 0.110.0
perl-Dist-CheckConflicts == 0.110.0-2:2014.1

Download

Type URL
Binary Package perl-Dist-CheckConflicts-0.110.0-2-rosa2014.1.noarch.rpm
Source Package perl-Dist-CheckConflicts-0.110.0-2.src.rpm

Install Howto

  1. Enable ROSA Main repository on Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Dist-CheckConflicts rpm package:
    # urpmi perl-Dist-CheckConflicts

Files

Path
/usr/lib/perl5/vendor_perl/5.18.2/Dist/CheckConflicts.pm
/usr/share/doc/perl-Dist-CheckConflicts/Changes
/usr/share/doc/perl-Dist-CheckConflicts/LICENSE
/usr/share/doc/perl-Dist-CheckConflicts/META.json
/usr/share/doc/perl-Dist-CheckConflicts/META.yml
/usr/share/doc/perl-Dist-CheckConflicts/README
/usr/share/man/man3/Dist::CheckConflicts.3pm.xz

Changelog

2014-06-27 - Alex Burmashev <alex.burmashev@rosalab.ru> 0.110.0-2
+ Revision: 49f3edf
- MassBuild#440: Increase release tag

See Also

Package Description
perl-Dpkg-1.17.1-3-rosa2014.1.noarch.rpm Package maintenance system for Debian Linux
perl-EV-4.180.0-1-rosa2014.1.x86_64.rpm Wrapper for the libev high-performance event loop library
perl-Email-Abstract-3.7.0-3-rosa2014.1.noarch.rpm Unified interface to mail representations
perl-Email-Address-1.905.0-2-rosa2014.1.noarch.rpm RFC 2822 Address Parsing and Creation
perl-Email-Date-1.104.0-3-rosa2014.1.noarch.rpm Find and Format Date Headers
perl-Email-Date-Format-1.4.0-3-rosa2014.1.noarch.rpm Produce RFC 2822 date strings
perl-Email-Simple-2.203.0-3-rosa2014.1.noarch.rpm Simple parsing of RFC2822 message format and headers
perl-Encode-Detect-1.10.0-9-rosa2014.1.x86_64.rpm An Encode::Encoding subclass that detects the encoding of data
perl-Encode-Locale-1.30.0-3-rosa2014.1.noarch.rpm Determine the locale encoding
perl-Error-0.170.220-3-rosa2014.1.noarch.rpm Error/exception handling in an OO-ish way
perl-Eval-Closure-0.110.0-3-rosa2014.1.noarch.rpm Safely and cleanly create closures via string eval
perl-Event-1.230.0-1-rosa2014.1.x86_64.rpm Event module for perl
perl-Event-ExecFlow-0.640.0-5-rosa2014.1.noarch.rpm Event-RPC - High level API for event-based execution flow control
perl-Event-File-0.1.1-5-rosa2014.1.noarch.rpm Mimic the 'tail -f' behaviour using Event
perl-Exception-Class-1.380.0-2-rosa2014.1.noarch.rpm A module that allows you to declare real exception classes in Perl
Advertisement
Advertisement