perl-Params-Util-1.70.0-7-rosa2014.1.x86_64.rpm


Advertisement

Description

perl-Params-Util - Simple standalone param-checking functions

Property Value
Distribution ROSA 2014.1
Repository ROSA Main x86_64
Package name perl-Params-Util
Package version 1.70.0
Package release 7-rosa2014.1
Package architecture x86_64
Package type rpm
Installed size 66.51 KB
Download size 25.66 KB
Official Mirror mirror.rosalab.ru
Params::Util provides a basic set of importable functions that makes checking
parameters a hell of a lot easier.

Alternatives

Package Version Architecture Repository
perl-Params-Util-1.70.0-7-rosa2014.1.i586.rpm 1.70.0 i586 ROSA Main
perl-Params-Util - - -

Requires

Name Value
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libperl.so.5.18()(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
perl(DynaLoader) -
perl(Exporter) -
perl(Scalar::Util) -
perl(abi) >= 5.18.2

Provides

Name Value
Util.so()(64bit) -
perl(Params::Util) == 1.70.0
perl-Params-Util == 1.70.0-7:2014.1

Download

Type URL
Binary Package perl-Params-Util-1.70.0-7-rosa2014.1.x86_64.rpm
Source Package perl-Params-Util-1.70.0-7.src.rpm

Install Howto

  1. Enable ROSA Main repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Params-Util rpm package:
    # urpmi perl-Params-Util

Files

Path
/usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi/Params/Util.pm
/usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi/auto/Params/
/usr/lib/perl5/vendor_perl/5.18.2/x86_64-linux-thread-multi/auto/Params/Util/Util.so
/usr/share/doc/perl-Params-Util/Changes
/usr/share/doc/perl-Params-Util/README
/usr/share/man/man3/Params::Util.3pm.xz

Changelog

2014-06-27 - Alex Burmashev <alex.burmashev@rosalab.ru> 1.70.0-7
+ Revision: 1949c9a
- MassBuild#440: Increase release tag

See Also

Package Description
perl-Params-Validate-1.130.0-1-rosa2014.1.x86_64.rpm Validate method/function call parameters
perl-Parse-RecDescent-1.967.9-2-rosa2014.1.noarch.rpm A recursive descent parser generator for Perl
perl-Parse-Yapp-1.50.0-8-rosa2014.1.noarch.rpm Fully reentrant perl OO LALR(1) parser creator
perl-PathTools-3.330.0-5-rosa2014.1.x86_64.rpm Tools for working with paths and file specs across platforms
perl-Period-1.200.0-7-rosa2014.1.noarch.rpm Time::Period module for perl
perl-Perl-Critic-1.121.0-3-rosa2014.1.noarch.rpm Critique Perl source for style and standards
perl-Perl-MinimumVersion-1.380.0-1-rosa2014.1.noarch.rpm Find a minimum required version of perl for Perl code
perl-PerlIO-gzip-0.180.0-8-rosa2014.1.x86_64.rpm Perl extension to provide a PerlIO layer to gzip/gunzip
perl-Pg-2.1.1-14-rosa2014.1.x86_64.rpm A libpq-based PostgreSQL interface for Perl
perl-PlRPC-0.2020-8-rosa2014.1.noarch.rpm PlRPC perl module
perl-Pod-Coverage-0.230.0-3-rosa2014.1.noarch.rpm Checks if the documentation of a perl module is comprehensive
perl-Pod-Escapes-1.40.0-7-rosa2014.1.noarch.rpm Perl module to resolve Pod E<...> sequences
perl-Pod-POM-0.290.0-3-rosa2014.1.noarch.rpm POD Object Model
perl-Pod-Perldoc-3.150.0-9-rosa2014.1.noarch.rpm Customized option parser for Pod::Perldoc
perl-Pod-Plainer-1.40.0-1-rosa2014.1.noarch.rpm To convert POD to old-style plainer POD
Advertisement
Advertisement