libqt5script-devel-5.5.1-5-rosa2014.1.i586.rpm


Advertisement

Description

libqt5script-devel - Development files for Qt Script

Property Value
Distribution ROSA 2014.1
Repository ROSA Main Updates i586
Package filename libqt5script-devel-5.5.1-5-rosa2014.1.i586.rpm
Package name libqt5script-devel
Package version 5.5.1
Package release 5-rosa2014.1
Package architecture i586
Package type rpm
Category Development/KDE and Qt
Homepage http://qt-project.org/
License LGPLv3+
Maintainer -
Download size 41.75 KB
Installed size 217.47 KB
Development files for Qt Script.

Alternatives

Package Version Architecture Repository
libqt5script-devel-5.6.1-1-rosa2014.1.i586.rpm 5.6.1 i586 ROSA Main Updates
libqt5script-devel-5.5.1-2.1-rosa2014.1.i586.rpm 5.5.1 i586 Stan8
libqt5script-devel-5.3.2-1-rosa2014.1.i586.rpm 5.3.2 i586 ROSA Main
libqt5script-devel - - -

Requires

Name Value
devel(libQt5Core) -
devel(libgcc_s) -
devel(libstdc++) -
libqt5script5 == 5.5.1-5:2014.1
pkgconfig(Qt5Core) -
qmake5 -

Provides

Name Value
devel(libQt5Script) -
libqt5script-devel == 5.5.1-5:2014.1
pkgconfig(Qt5Script) == 5.5.1

Download

Type URL
Mirror mirror.rosalab.ru
Binary Package libqt5script-devel-5.5.1-5-rosa2014.1.i586.rpm
Source Package qt5-5.5.1-5.src.rpm

Install Howto

  1. Enable ROSA Main Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libqt5script-devel rpm package:
    # urpmi libqt5script-devel

Files

Path
/usr/include/qt5/QtScript/QScriptClass
/usr/include/qt5/QtScript/QScriptClassPropertyIterator
/usr/include/qt5/QtScript/QScriptContext
/usr/include/qt5/QtScript/QScriptContextInfo
/usr/include/qt5/QtScript/QScriptContextInfoList
/usr/include/qt5/QtScript/QScriptEngine
/usr/include/qt5/QtScript/QScriptEngineAgent
/usr/include/qt5/QtScript/QScriptExtensionInterface
/usr/include/qt5/QtScript/QScriptExtensionPlugin
/usr/include/qt5/QtScript/QScriptProgram
/usr/include/qt5/QtScript/QScriptString
/usr/include/qt5/QtScript/QScriptSyntaxCheckResult
/usr/include/qt5/QtScript/QScriptValue
/usr/include/qt5/QtScript/QScriptValueIterator
/usr/include/qt5/QtScript/QScriptValueList
/usr/include/qt5/QtScript/QScriptable
/usr/include/qt5/QtScript/QtScript
/usr/include/qt5/QtScript/QtScriptDepends
/usr/include/qt5/QtScript/QtScriptVersion
/usr/include/qt5/QtScript/qscriptable.h
/usr/include/qt5/QtScript/qscriptclass.h
/usr/include/qt5/QtScript/qscriptclasspropertyiterator.h
/usr/include/qt5/QtScript/qscriptcontext.h
/usr/include/qt5/QtScript/qscriptcontextinfo.h
/usr/include/qt5/QtScript/qscriptengine.h
/usr/include/qt5/QtScript/qscriptengineagent.h
/usr/include/qt5/QtScript/qscriptextensioninterface.h
/usr/include/qt5/QtScript/qscriptextensionplugin.h
/usr/include/qt5/QtScript/qscriptprogram.h
/usr/include/qt5/QtScript/qscriptstring.h
/usr/include/qt5/QtScript/qscriptvalue.h
/usr/include/qt5/QtScript/qscriptvalueiterator.h
/usr/include/qt5/QtScript/qtscriptglobal.h
/usr/include/qt5/QtScript/qtscriptversion.h
/usr/include/qt5/QtScript/5.5.1/
/usr/include/qt5/QtScript/5.5.1/QtScript/
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptable_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptactivationobject_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptast_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptastfwd_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptastvisitor_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptclassobject_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptcontext_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptdeclarativeclass_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptdeclarativeobject_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptengine_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptengineagent_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptfunction_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptglobalobject_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptgrammar_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptlexer_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptobject_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptparser_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptprogram_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptqobject_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptstaticscopeobject_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptstring_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptsyntaxchecker_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptvalue_p.h
/usr/include/qt5/QtScript/5.5.1/QtScript/private/qscriptvariant_p.h
/usr/lib/libQt5Script.prl
/usr/lib/libQt5Script.so
/usr/lib/cmake/Qt5Script/Qt5ScriptConfig.cmake
/usr/lib/cmake/Qt5Script/Qt5ScriptConfigVersion.cmake
/usr/lib/pkgconfig/Qt5Script.pc

Changelog

2016-03-30 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.5.1-5
- (1c2e870) Less strict Requires for qt5-macros (no EVRD)
- (Andrey Bondrov: fd88acb) Change Requires to Suggests for i18n subpackages
2016-03-15 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.5.1-4
- (e7bc0ac) Build with docs again
2016-03-14 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.5.1-3
- (0c7221b) Build without docs
- (Andrey Bondrov: bd08a43) Try to fix build with system nss 3.23 (sync API)
- (Andrey Bondrov: 6e4311a) Bump release
2016-02-01 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.5.1-2
- (ae197ed) Add patches from OpenSUSE to fix QTBUG-48870 and to refactor FxViewItem releasing code
2015-10-17 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.5.1-1
- (71519da) Make sure devel package requires new development subpackages
- (71519da) Rebuild with docs
2015-10-16 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.5.1-0.1
- (17f0fad) Add subpackages for Qt3DCollision and Qt3DLogic libraries and developent files
- (Andrey Bondrov: 299823b) Add glTF sceneparser subpackage
- (Andrey Bondrov: ab3bcb2) Update files (add more data files for Qt WebEngine)
- (Andrey Bondrov: b14ba8a) Update files (add more translations)
- (Andrey Bondrov: e3ce454) New version 5.5.1
- (Andrey Bondrov: e3ce454) Drop merged patches
- (Andrey Bondrov: e3ce454) Build without docs
2015-09-25 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.5.0-3
- (21c4751) Try to build without libproxy support to fix crash in QtWebKit
2015-09-25 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.5.0-2
- (925f982) Fix summaries for some packages
- (Andrey Bondrov: e11180e) Development Qt5Gui package should also require xcb-integration-plugin-* packages
- (Andrey Bondrov: bd0676c) Development Qt5Gui package should require eglfs-integration-plugin-* packages
2015-09-17 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.5.0-1
- (f6a2ded) Rebuild with docs enabled
2015-09-16 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.5.0-0.1
- (f7e4473) Development package shouldn't require obsolete qtgui-kms package
- (Andrey Bondrov: 6ae4a94) Build requires pkgconfig(bluez)
- (Andrey Bondrov: 7db7b37) Add various bugfix patches from Fedora
- (Andrey Bondrov: abd76b0) Fix a typo

See Also

Package Description
libqt5script5-5.5.1-5-rosa2014.1.i586.rpm Qt Script runtime library
libqt5script5-5.6.1-1-rosa2014.1.i586.rpm Qt Script runtime library
libqt5scripttools-devel-5.5.1-5-rosa2014.1.i586.rpm Development files for Qt Script tools
libqt5scripttools-devel-5.6.1-1-rosa2014.1.i586.rpm Development files for Qt Script tools
libqt5scripttools5-5.5.1-5-rosa2014.1.i586.rpm Qt Script tools library
libqt5scripttools5-5.6.1-1-rosa2014.1.i586.rpm Qt Script tools library
libqt5sensors-devel-5.5.1-5-rosa2014.1.i586.rpm Development files for the QtSensors library
libqt5sensors-devel-5.6.1-1-rosa2014.1.i586.rpm Development files for the QtSensors library
libqt5sensors5-5.5.1-5-rosa2014.1.i586.rpm Qt Sensors library
libqt5sensors5-5.6.1-1-rosa2014.1.i586.rpm Qt Sensors library
libqt5serialbus-devel-5.6.1-1-rosa2014.1.i586.rpm Development files for the Serial Bus library
libqt5serialbus5-5.6.1-1-rosa2014.1.i586.rpm Qt Serial Bus library
libqt5serialport-devel-5.5.1-5-rosa2014.1.i586.rpm Development files for the QtSerialPort library
libqt5serialport-devel-5.6.1-1-rosa2014.1.i586.rpm Development files for the QtSerialPort library
libqt5serialport5-5.5.1-5-rosa2014.1.i586.rpm Qt Serial Port library
Advertisement
Advertisement