perl-Perl-Critic-Dynamic-0.50.0-3-rosa2016.1.noarch.rpm


Advertisement

Description

perl-Perl-Critic-Dynamic - Non-static policies for Perl::Critic

Property Value
Distribution ROSA 2016.1
Repository ROSA Contrib x86_64
Package filename perl-Perl-Critic-Dynamic-0.50.0-3-rosa2016.1.noarch.rpm
Package name perl-Perl-Critic-Dynamic
Package version 0.50.0
Package release 3-rosa2016.1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Perl-Critic-Dynamic/
License GPL+ or Artistic
Maintainer -
Download size 20.60 KB
Installed size 39.85 KB
Perl::Critic is primarily used as a static source code analyzer, which means
that it never compiles or executes any of the code that it examines. But
since Perl is a dynamic language, there are certain types of problems that
cannot be discovered until the code is actually compiled.
This distribution includes Perl::Critic::DynamicPolicy, which can be used as
a base class for Policies that wish to compile the code they analyze.

Alternatives

Package Version Architecture Repository
perl-Perl-Critic-Dynamic-0.50.0-3-rosa2016.1.noarch.rpm 0.50.0 noarch ROSA Contrib
perl-Perl-Critic-Dynamic - - -

Requires

Name Value
perl(Carp) -
perl(Devel::Symdump) -
perl(English) -
perl(Perl::Critic::Policy) -
perl(Perl::Critic::Utils) -
perl(Readonly) -
perl(abi) >= 5.20.3

Provides

Name Value
perl(Perl::Critic::Dynamic) == 0.50.0
perl(Perl::Critic::DynamicPolicy) == 0.50.0
perl(Perl::Critic::Policy::Dynamic::ValidateAgainstSymbolTable) == 0.50.0
perl-Perl-Critic-Dynamic == 0.50.0-3:2016.1

Download

Type URL
Mirror mirror.rosalab.ru
Binary Package perl-Perl-Critic-Dynamic-0.50.0-3-rosa2016.1.noarch.rpm
Source Package perl-Perl-Critic-Dynamic-0.50.0-3.src.rpm

Install Howto

  1. Enable ROSA Contrib repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Perl-Critic-Dynamic rpm package:
    # urpmi perl-Perl-Critic-Dynamic

Files

Path
/usr/lib/perl5/vendor_perl/5.20.3/Perl/
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/Dynamic.pm
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/DynamicPolicy.pm
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/Policy/
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/Policy/Dynamic/ValidateAgainstSymbolTable.pm
/usr/share/doc/perl-Perl-Critic-Dynamic/Changes
/usr/share/doc/perl-Perl-Critic-Dynamic/README
/usr/share/man/man3/Perl::Critic::Dynamic.3pm.xz
/usr/share/man/man3/Perl::Critic::DynamicPolicy.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Dynamic::ValidateAgainstSymbolTable.3pm.xz

Changelog

2017-03-02 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 0.50.0-3
- (f48fde3) MassBuild#1273: Increase release tag

See Also

Package Description
perl-Perl-Critic-Itch-0.70.0-3-rosa2016.1.noarch.rpm A collection of Perl::Critic Policies to solve some Itches
perl-Perl-Critic-Lax-0.11.0-3-rosa2016.1.noarch.rpm Policies that let you slide on common exceptions
perl-Perl-Critic-Moose-1.30.0-3-rosa2016.1.noarch.rpm Policies for Perl::Critic concerned with using Moose
perl-Perl-Critic-More-1.3.0-5-rosa2016.1.noarch.rpm Stop mixing long strings with code
perl-Perl-Critic-Nits-1.0.0-7-rosa2016.1.noarch.rpm Policies of nits I like to pick
perl-Perl-Critic-PetPeeves-JTRAMMELL-0.40.0-4-rosa2016.1.noarch.rpm Prohibit superfluous initializations
perl-Perl-Critic-Pulp-90.0.0-3-rosa2016.1.noarch.rpm Don't use Foo:: style barewords
perl-Perl-Critic-Storable-0.10.0-7-rosa2016.1.noarch.rpm Perl::Critic policy for using Storable
perl-Perl-Critic-StricterSubs-0.30.0-7-rosa2016.1.noarch.rpm Perl::Critic plugin for stricter subroutine checks
perl-Perl-Critic-Swift-1.0.3-6-rosa2016.1.noarch.rpm Additional policies for Perl::Critic
perl-Perl-Critic-Tics-0.9.0-3-rosa2016.1.noarch.rpm Extra policies for Perl::Critic
perl-Perl-Metrics-Simple-0.180.0-3-rosa2016.1.noarch.rpm Methods analyzing a single file
perl-Perl-MinimumVersion-1.380.0-4-rosa2016.1.noarch.rpm Find a minimum required version of perl for Perl code
perl-Perl-OSType-1.8.0-3-rosa2016.1.noarch.rpm Map Perl operating system names to generic types
perl-Perl-PrereqScanner-1.23.0-3-rosa2016.1.noarch.rpm Scan for modules loaded with superclass.pm
Advertisement
Advertisement