perl-Perl-Critic-Moose-1.30.0-3-rosa2016.1.noarch.rpm


Advertisement

Description

perl-Perl-Critic-Moose - Policies for Perl::Critic concerned with using Moose

Property Value
Distribution ROSA 2016.1
Repository ROSA Contrib x86_64
Package filename perl-Perl-Critic-Moose-1.30.0-3-rosa2016.1.noarch.rpm
Package name perl-Perl-Critic-Moose
Package version 1.30.0
Package release 3-rosa2016.1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Perl-Critic-Moose/
License GPL+ or Artistic
Maintainer -
Download size 29.42 KB
Installed size 98.92 KB
Some Perl::Critic policies that will help you keep your code in good shape
with regards to Moose.

Alternatives

Package Version Architecture Repository
perl-Perl-Critic-Moose-1.30.0-3-rosa2016.1.noarch.rpm 1.30.0 noarch ROSA Contrib
perl-Perl-Critic-Moose - - -

Requires

Name Value
perl(Perl::Critic::Policy) -
perl(Perl::Critic::Utils) -
perl(Perl::Critic::Utils::PPI) -
perl(Readonly) -
perl(abi) >= 5.20.3

Provides

Name Value
perl(Perl::Critic::Moose) == 1.30.0
perl(Perl::Critic::Policy::Moose::ProhibitDESTROYMethod) == 1.30.0
perl(Perl::Critic::Policy::Moose::ProhibitMultipleWiths) == 1.30.0
perl(Perl::Critic::Policy::Moose::ProhibitNewMethod) == 1.30.0
perl(Perl::Critic::Policy::Moose::RequireCleanNamespace) == 1.30.0
perl(Perl::Critic::Policy::Moose::RequireMakeImmutable) == 1.30.0
perl-Perl-Critic-Moose == 1.30.0-3:2016.1

Download

Type URL
Mirror mirror.rosalab.ru
Binary Package perl-Perl-Critic-Moose-1.30.0-3-rosa2016.1.noarch.rpm
Source Package perl-Perl-Critic-Moose-1.30.0-3.src.rpm

Install Howto

  1. Enable ROSA Contrib repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Perl-Critic-Moose rpm package:
    # urpmi perl-Perl-Critic-Moose

Files

Path
/usr/lib/perl5/vendor_perl/5.20.3/Perl/
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/Moose.pm
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/Policy/
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/Policy/Moose/ProhibitDESTROYMethod.pm
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/Policy/Moose/ProhibitMultipleWiths.pm
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/Policy/Moose/ProhibitNewMethod.pm
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/Policy/Moose/RequireCleanNamespace.pm
/usr/lib/perl5/vendor_perl/5.20.3/Perl/Critic/Policy/Moose/RequireMakeImmutable.pm
/usr/share/doc/perl-Perl-Critic-Moose/Changes
/usr/share/doc/perl-Perl-Critic-Moose/LICENSE
/usr/share/doc/perl-Perl-Critic-Moose/META.json
/usr/share/doc/perl-Perl-Critic-Moose/META.yml
/usr/share/doc/perl-Perl-Critic-Moose/README.md
/usr/share/man/man3/Perl::Critic::Moose.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Moose::ProhibitDESTROYMethod.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Moose::ProhibitMultipleWiths.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Moose::ProhibitNewMethod.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Moose::RequireCleanNamespace.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Moose::RequireMakeImmutable.3pm.xz

Changelog

2017-03-02 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 1.30.0-3
- (a04eb55) MassBuild#1273: Increase release tag

See Also

Package Description
perl-Perl-Critic-More-1.3.0-5-rosa2016.1.noarch.rpm Stop mixing long strings with code
perl-Perl-Critic-Nits-1.0.0-7-rosa2016.1.noarch.rpm Policies of nits I like to pick
perl-Perl-Critic-PetPeeves-JTRAMMELL-0.40.0-4-rosa2016.1.noarch.rpm Prohibit superfluous initializations
perl-Perl-Critic-Pulp-90.0.0-3-rosa2016.1.noarch.rpm Don't use Foo:: style barewords
perl-Perl-Critic-Storable-0.10.0-7-rosa2016.1.noarch.rpm Perl::Critic policy for using Storable
perl-Perl-Critic-StricterSubs-0.30.0-7-rosa2016.1.noarch.rpm Perl::Critic plugin for stricter subroutine checks
perl-Perl-Critic-Swift-1.0.3-6-rosa2016.1.noarch.rpm Additional policies for Perl::Critic
perl-Perl-Critic-Tics-0.9.0-3-rosa2016.1.noarch.rpm Extra policies for Perl::Critic
perl-Perl-Metrics-Simple-0.180.0-3-rosa2016.1.noarch.rpm Methods analyzing a single file
perl-Perl-MinimumVersion-1.380.0-4-rosa2016.1.noarch.rpm Find a minimum required version of perl for Perl code
perl-Perl-OSType-1.8.0-3-rosa2016.1.noarch.rpm Map Perl operating system names to generic types
perl-Perl-PrereqScanner-1.23.0-3-rosa2016.1.noarch.rpm Scan for modules loaded with superclass.pm
perl-Perl-Version-1.13.0-3-rosa2016.1.noarch.rpm Parse and manipulate Perl version strings
perl-Perl6-Doc-0.470.0-7-rosa2016.1.noarch.rpm Perl 6 Documentation Collection
perl-Perl6-Export-0.70.0-6-rosa2016.1.noarch.rpm Implements the Perl 6 is export trait
Advertisement
Advertisement