perl-Test-CPAN-Meta-JSON-0.160.0-3-rosa2016.1.noarch.rpm


Advertisement

Description

perl-Test-CPAN-Meta-JSON - Validate CPAN META data against the specification

Property Value
Distribution ROSA 2016.1
Repository ROSA Contrib x86_64
Package filename perl-Test-CPAN-Meta-JSON-0.160.0-3-rosa2016.1.noarch.rpm
Package name perl-Test-CPAN-Meta-JSON
Package version 0.160.0
Package release 3-rosa2016.1
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/Test-CPAN-Meta-JSON
License GPL+ or Artistic
Maintainer -
Download size 22.08 KB
Installed size 55.15 KB
This module was written to ensure that a META.json file, provided with a
standard distribution uploaded to CPAN, meets the specifications that are
slowly being introduced to module uploads, via the use of package makers
and installers such as the ExtUtils::MakeMaker manpage, the Module::Build
manpage and the Module::Install manpage.
See the CPAN::Meta manpage for further details of the CPAN Meta
Specification.

Alternatives

Package Version Architecture Repository
perl-Test-CPAN-Meta-JSON-0.160.0-3-rosa2016.1.noarch.rpm 0.160.0 noarch ROSA Contrib
perl-Test-CPAN-Meta-JSON - - -

Requires

Name Value
perl(IO::File) -
perl(JSON) -
perl(Test::Builder) -
perl(abi) >= 5.20.3

Provides

Name Value
perl(Test::CPAN::Meta::JSON) == 0.160.0
perl(Test::CPAN::Meta::JSON::Version) == 0.160.0
perl-Test-CPAN-Meta-JSON == 0.160.0-3:2016.1

Download

Type URL
Mirror mirror.rosalab.ru
Binary Package perl-Test-CPAN-Meta-JSON-0.160.0-3-rosa2016.1.noarch.rpm
Source Package perl-Test-CPAN-Meta-JSON-0.160.0-3.src.rpm

Install Howto

  1. Enable ROSA Contrib repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Test-CPAN-Meta-JSON rpm package:
    # urpmi perl-Test-CPAN-Meta-JSON

Files

Path
/usr/lib/perl5/vendor_perl/5.20.3/Test/
/usr/lib/perl5/vendor_perl/5.20.3/Test/CPAN/
/usr/lib/perl5/vendor_perl/5.20.3/Test/CPAN/Meta/JSON.pm
/usr/lib/perl5/vendor_perl/5.20.3/Test/CPAN/Meta/JSON/Version.pm
/usr/share/doc/perl-Test-CPAN-Meta-JSON/Changes
/usr/share/doc/perl-Test-CPAN-Meta-JSON/LICENSE
/usr/share/doc/perl-Test-CPAN-Meta-JSON/META.json
/usr/share/doc/perl-Test-CPAN-Meta-JSON/META.yml
/usr/share/doc/perl-Test-CPAN-Meta-JSON/README
/usr/share/doc/perl-Test-CPAN-Meta-JSON/examples/96metatest.t
/usr/share/doc/perl-Test-CPAN-Meta-JSON/examples/97metatest.t
/usr/share/doc/perl-Test-CPAN-Meta-JSON/examples/examples.txt
/usr/share/man/man3/Test::CPAN::Meta::JSON.3pm.xz
/usr/share/man/man3/Test::CPAN::Meta::JSON::Version.3pm.xz

Changelog

2017-03-02 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 0.160.0-3
- (eca4aa4) MassBuild#1273: Increase release tag

See Also

Package Description
perl-Test-CPAN-Meta-YAML-0.250.0-3-rosa2016.1.noarch.rpm Validate META.json elements
perl-Test-CheckChanges-0.140.0-9-rosa2016.1.noarch.rpm Check that the Changes file matches the dist
perl-Test-CheckDeps-0.10.0-5-rosa2016.1.noarch.rpm Check for presence of dependencies
perl-Test-CheckManifest-1.280.0-3-rosa2016.1.noarch.rpm Check if your Manifest matches your distro
perl-Test-Class-0.500.0-4-rosa2016.1.noarch.rpm Write Perl test suites in xUnit style
perl-Test-Class-Most-0.80.0-3-rosa2016.1.noarch.rpm Test Classes the easy way
perl-Test-Cmd-1.80.0-3-rosa2016.1.noarch.rpm Perl module for portable testing of commands and scripts
perl-Test-Command-0.110.0-5-rosa2016.1.noarch.rpm Test routines for external commands
perl-Test-Compile-1.2.1-3-rosa2016.1.noarch.rpm Check whether Perl module files compile correctly
perl-Test-ConsistentVersion-0.3.0-3-rosa2016.1.noarch.rpm Ensures distribution versions are consistent
perl-Test-Corpus-Audio-MPD-1.120.990-5-rosa2016.1.noarch.rpm Automate launching of fake mdp for testing purposes
perl-Test-Cukes-0.100.0-7-rosa2016.1.noarch.rpm A BBD test tool inspired by Cucumber
perl-Test-Deep-JSON-0.30.0-3-rosa2016.1.noarch.rpm Compare JSON with Test::Deep
perl-Test-Deep-Type-0.6.0-3-rosa2016.1.noarch.rpm A Test::Deep plugin for validating type constraints
perl-Test-Dependencies-0.120.0-6-rosa2016.1.noarch.rpm Ensure that your Makefile.PL specifies all module dependencies
Advertisement
Advertisement