perl-Package-DeprecationManager-0.170.0-1-rosa2016.1.noarch.rpm


Advertisement

Description

perl-Package-DeprecationManager - Manage deprecation warnings for your distribution

Property Value
Distribution ROSA 2016.1
Repository ROSA Contrib Updates x86_64
Package name perl-Package-DeprecationManager
Package version 0.170.0
Package release 1-rosa2016.1
Package architecture noarch
Package type rpm
Installed size 76.90 KB
Download size 21.88 KB
Official Mirror mirror.rosalab.ru
This module allows you to manage a set of deprecations for one or more
modules.
When you import 'Package::DeprecationManager', you must provide a set of
'-deprecations' as a hash ref. The keys are "feature" names, and the values
are the version when that feature was deprecated.
In many cases, you can simply use the fully qualified name of a subroutine
or method as the feature name. This works for cases where the whole
subroutine is deprecated. However, the feature names can be any string.
This is useful if you don't want to deprecate an entire subroutine, just a
certain usage.

Alternatives

Package Version Architecture Repository
perl-Package-DeprecationManager-0.170.0-1-rosa2016.1.noarch.rpm 0.170.0 noarch ROSA Contrib Updates
perl-Package-DeprecationManager-0.150.0-4-rosa2016.1.noarch.rpm 0.150.0 noarch ROSA Contrib
perl-Package-DeprecationManager-0.150.0-4-rosa2016.1.noarch.rpm 0.150.0 noarch ROSA Contrib
perl-Package-DeprecationManager - - -

Requires

Name Value
perl(Carp) -
perl(List::Util) >= 1.330.0
perl(Package::Stash) -
perl(Params::Util) -
perl(Sub::Install) -
perl(Sub::Name) -
perl(abi) >= 5.20.3

Provides

Name Value
perl(Package::DeprecationManager) == 0.170.0
perl-Package-DeprecationManager == 0.170.0-1:2016.1

Download

Type URL
Binary Package perl-Package-DeprecationManager-0.170.0-1-rosa2016.1.noarch.rpm
Source Package perl-Package-DeprecationManager-0.170.0-1.src.rpm

Install Howto

  1. Enable ROSA Contrib Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Package-DeprecationManager rpm package:
    # urpmi perl-Package-DeprecationManager

Files

Path
/usr/lib/perl5/vendor_perl/5.20.3/Package/DeprecationManager.pm
/usr/share/doc/perl-Package-DeprecationManager/Changes
/usr/share/doc/perl-Package-DeprecationManager/LICENSE
/usr/share/doc/perl-Package-DeprecationManager/META.json
/usr/share/doc/perl-Package-DeprecationManager/META.yml
/usr/share/man/man3/Package::DeprecationManager.3pm.xz

Changelog

2017-06-22 - dsilakov <denis.silakov@rosalab.ru> 0.170.0-1
- (8e7a710) Merge pull request #3 from import/perl-Package-DeprecationManager:auto_update
- (8e7a710) Updated to 0.17 (by updates_builder)

See Also

Package Description
perl-Perl-Critic-1.130.0-2-rosa2016.1.noarch.rpm Critique Perl source for style and standards
perl-PerlIO-gzip-0.200.0-1-rosa2016.1.x86_64.rpm Perl extension to provide a PerlIO layer to gzip/gunzip
perl-Pod-Spell-1.200.0-1-rosa2016.1.noarch.rpm A formatter for spellchecking Pod
perl-SVG-2.840.0-1-rosa2016.1.noarch.rpm Perl extension for generating Scalable Vector Graphics (SVG) documents
perl-Specio-0.380.0-1-rosa2016.1.noarch.rpm A class which represents parameterizable constraints
perl-Sub-Info-0.2.0-1-rosa2016.1.noarch.rpm Tool for inspecting subroutines
perl-Sys-Virt-3.9.1-1-rosa2016.1.x86_64.rpm Interface to libvirt virtual machine management API
perl-Template-Toolkit-2.270.0-1-rosa2016.1.x86_64.rpm Template-Toolkit module for perl
perl-Test-Memory-Cycle-1.60.0-1-rosa2016.1.noarch.rpm Check for memory leaks and circular memory references
perl-Test-Most-0.350.0-1-rosa2016.1.noarch.rpm Most commonly needed test functions and features
perl-Test-Warn-0.320.0-3-rosa2016.1.noarch.rpm Perl extension to test methods for warnings
perl-Test2-Suite-0.000072-1-rosa2016.1.noarch.rpm Set of tools built upon the Test2 framework
perl-Text-CSV_XS-1.350.0-1-rosa2016.1.x86_64.rpm Comma-separated values manipulation routines
perl-WWW-Mechanize-1.840.0-1-rosa2016.1.noarch.rpm Handy web browsing in a Perl object
perl-XML-LibXSLT-1.950.0-1-rosa2016.1.x86_64.rpm Perl interface to the gnome libxslt library
Advertisement
Advertisement