libqt5xcbqpa5-glx-5.11.2-0.2-rosa2016.1.i586.rpm


Advertisement

Description

libqt5xcbqpa5-glx - GLX support for the Qt XCB QPA library v5

Property Value
Distribution ROSA 2016.1
Repository ROSA Main Updates i586
Package filename libqt5xcbqpa5-glx-5.11.2-0.2-rosa2016.1.i586.rpm
Package name libqt5xcbqpa5-glx
Package version 5.11.2
Package release 0.2-rosa2016.1
Package architecture i586
Package type rpm
Category System/Libraries
Homepage http://qt-project.org/
License LGPLv3+
Maintainer -
Download size 27.36 KB
Installed size 61.41 KB
GLX support for the Qt XCB QPA library v5.

Alternatives

Package Version Architecture Repository
libqt5xcbqpa5-glx-5.8.0-4-rosa2016.1.i586.rpm 5.8.0 i586 ROSA Main
libqt5xcbqpa5-glx - - -

Requires

Name Value
libGL.so.1 -
libQt5Core.so.5 -
libQt5Core.so.5(Qt_5) -
libQt5Core.so.5(Qt_5.11) -
libQt5Gui.so.5 -
libQt5Gui.so.5(Qt_5) -
libQt5Gui.so.5(Qt_5.11.2_PRIVATE_API) -
libQt5XcbQpa.so.5 -
libQt5XcbQpa.so.5(Qt_5.11.2_PRIVATE_API) -
libX11.so.6 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.4) -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.4) -
libqt5xcbqpa5 == 5.11.2-0.2:2016.1
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libxcb-glx.so.0 -
libxcb.so.1 -

Provides

Name Value
libqt5xcbqpa5-glx == 5.11.2-0.2:2016.1
libqxcb-glx-integration.so -
qt5-xcb-integration-plugin == 5.11.2-0.2:2016.1
qt5-xcb-integration-plugin-default == 5.11.2-0.2:2016.1
qt5-xcb-integration-plugin-glx == 5.11.2-0.2:2016.1

Download

Type URL
Mirror mirror.rosalab.ru
Binary Package libqt5xcbqpa5-glx-5.11.2-0.2-rosa2016.1.i586.rpm
Source Package qt5-qtbase-5.11.2-0.2.src.rpm

Install Howto

  1. Enable ROSA Main Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libqt5xcbqpa5-glx rpm package:
    # urpmi libqt5xcbqpa5-glx

Files

Path
/usr/lib/qt5/plugins/xcbglintegrations/libqxcb-glx-integration.so

Changelog

2018-12-13 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.11.2-0.2
- (8a1cd88) Disable O_TMPFILE support (keep pre-5.10 Qt behavior)
2018-10-20 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.11.2-0.1
- (8d6c784) Add qt5-platformtheme-flatpak package
- (8d6c784) Update files
- (Andrey Bondrov: 4460d01) Build without docs first
2018-10-20 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.11.2-1
- (c1169a4) Drop backported QTBUG-66103 patch
- (Andrey Bondrov: e39e021) Add missing QT_VERSION_CHECK patch
- (Andrey Bondrov: 069353b) Add missing LFLAGS patch
- (Andrey Bondrov: 9d9b746) Sync some patches with Fedora
- (Andrey Bondrov: 89e6352) Adjust sources tarball name (opensource-src -> everywhere-src)
- (Andrey Bondrov: 7228168) New version 5.11.2
2018-02-01 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.9.4-2
- (fc597aa) Add patch to fix QTBUG-66103
2018-01-24 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.9.4-1
- (5a8707f) New version 5.9.4
2017-12-13 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.9.3-2
- (0c18989) Revert upstream commits to avoid QUrl behaviour change
2017-11-23 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.9.3-1
- (f59d4b5) New version 5.9.3
2017-11-05 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.9.2-1
- (a36f519) Add QtLinuxAccessibilitySupport files to Qt5Gui development files
- (Andrey Bondrov: 84e8c2f) New version 5.9.2
2017-08-20 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.9.1-1
- (0ba3885) Update files (replace QtLinuxAccessibilitySupport with QtKmsSupport)
- (0ba3885) Add new subpackage for qt5-eglfs-integration-plugin-emu
- (Andrey Bondrov: 0730364) Drop merged QTBUG-56140 patch
- (Andrey Bondrov: 605b765) New version 5.9.1
2017-02-28 - Andrey Bondrov <andrey.bondrov@rosalab.ru> 5.8.0-4
- (1a738c3) Add some bugfix patches from upstream and Fedora (mostly HighDPI-related)

See Also

Package Description
libqt5xml-devel-5.11.2-0.2-rosa2016.1.i586.rpm Development files for version 5 of the Qt XML library
libqt5xml5-5.11.2-0.2-rosa2016.1.i586.rpm Qt XML library
libqt5xmlpatterns-devel-5.11.2-1-rosa2016.1.i586.rpm Development files for Qt's XSLT engine
libqt5xmlpatterns5-5.11.2-1-rosa2016.1.i586.rpm Qt XSLT engine
libqtav-devel-1.12.0-5-rosa2016.1.i586.rpm QtAV development files
libqtav-qml-1.12.0-5-rosa2016.1.i586.rpm QML plugin for Qt5 multimedia framework
libqtav1-1.12.0-5-rosa2016.1.i586.rpm QtAV shared library
libqtavwidgets1-1.12.0-5-rosa2016.1.i586.rpm QtAV Widgets shared library
libqtcurve-cairo1-1.8.18-2.20170506.2-rosa2016.1.i586.rpm Shared library for QtCurve
libqtcurve-gtk2-1.8.18-2.20170506.2-rosa2016.1.i586.rpm GTK2 libraries for QtCurve
libqtcurve-utils2-1.8.18-2.20170506.2-rosa2016.1.i586.rpm Shared library for QtCurve
libquadmath-devel-5.5.0_2017.10-2-rosa2016.1.i586.rpm GCC __float128 support
libquadmath-static-devel-5.5.0_2017.10-2-rosa2016.1.i586.rpm Static libraries for __float128 support
libquadmath0-5.5.0_2017.10-2-rosa2016.1.i586.rpm GCC __float128 shared support library
libquazip-devel-0.7.6-1-rosa2016.1.i586.rpm Development files for quazip
Advertisement
Advertisement